Knowledge Base
MilesWeb / Web Hosting FAQ

Ioncube error with litespeed web server

Approx. read time : 2 min

After installing litespeed on your server with cPanel, you might receive error as below.

Site error: the file configgeneral.php requires the ionCube PHP Loader ioncube_loader_lin_4.4.so to be installed by the website operator. If you are the website operator please use the ionCube Loader Wizard to assist with installation.

This is because the version of Apache php binary & LiteSpeed php binary do not match. You will have to build matching php binary.

Login to WHM as root & access option Main >> Plugins >> LiteSpeed Web Server Plugin. Click on “Build Matching PHP Binary”.

ioncube issues with litespeed

Tick the option “Build Matching PHP 5.3.24 with LSAPI” & click Next. It will build lsphp using the same configuration as Apache’s php. This will download the source code and build php binary. The whole process may take more than 10 minutes.

Once completed, Ioncube will work properly with litespeed. You can install litespeed on linux dedicated server & linux VPS

Save

Admin
With over 10+ years of experience in the web hosting industry, I have achieved extensive exposure to result-oriented methodologies. And expertise in different domains like Datacentre Services, Cloud computing technology, Web hosting industry and many more.